#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?i)m[^A-Za-z0-9]*e[^A-Za-z0-9]*d[^A-Za-z0-9]*i[^A-Za-z0-9]*a[^A-Za-z0-9]*t[^A-Za-z0-9]*i[^A-Za-z0-9]*z[^A-Za-z0-9]*e\b"
Local $sString = "mediatize" & @CRLF & _
"m_e_d_i_a_t_i_z_e" & @CRLF & _
"m e d i a t i z e" & @CRLF & _
"m__e__d__i__a__t__i__z__e" & @CRLF & _
"m·e·d·i·a·t·i·z·e" & @CRLF & _
"MEDIATIZE" & @CRLF & _
"M_E_D_I_A_t_i_z_e" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")