import Foundation
let pattern = #"\b(?i)m[^A-Za-z0-9]*e[^A-Za-z0-9]*d[^A-Za-z0-9]*i[^A-Za-z0-9]*a[^A-Za-z0-9]*t[^A-Za-z0-9]*i[^A-Za-z0-9]*z[^A-Za-z0-9]*e\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
mediatize
m_e_d_i_a_t_i_z_e
m e d i a t i z e
m__e__d__i__a__t__i__z__e
m·e·d·i·a·t·i·z·e
MEDIATIZE
M_E_D_I_A_t_i_z_e
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)