import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?i)m[^A-Za-z0-9]*e[^A-Za-z0-9]*d[^A-Za-z0-9]*i[^A-Za-z0-9]*a[^A-Za-z0-9]*t[^A-Za-z0-9]*i[^A-Za-z0-9]*z[^A-Za-z0-9]*e\\b";
final String string = "mediatize\n"
+ "m_e_d_i_a_t_i_z_e\n"
+ "m e d i a t i z e\n"
+ "m__e__d__i__a__t__i__z__e\n"
+ "m·e·d·i·a·t·i·z·e\n"
+ "MEDIATIZE\n"
+ "M_E_D_I_A_t_i_z_e\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}