// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?i)m[^A-Za-z0-9]*e[^A-Za-z0-9]*d[^A-Za-z0-9]*i[^A-Za-z0-9]*a[^A-Za-z0-9]*t[^A-Za-z0-9]*i[^A-Za-z0-9]*z[^A-Za-z0-9]*e\b").unwrap();
let string = "mediatize
m_e_d_i_a_t_i_z_e
m e d i a t i z e
m__e__d__i__a__t__i__z__e
m·e·d·i·a·t·i·z·e
MEDIATIZE
M_E_D_I_A_t_i_z_e
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}