const regex = /\b(?i)m[^A-Za-z0-9]*e[^A-Za-z0-9]*d[^A-Za-z0-9]*i[^A-Za-z0-9]*a[^A-Za-z0-9]*t[^A-Za-z0-9]*i[^A-Za-z0-9]*z[^A-Za-z0-9]*e\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?i)m[^A-Za-z0-9]*e[^A-Za-z0-9]*d[^A-Za-z0-9]*i[^A-Za-z0-9]*a[^A-Za-z0-9]*t[^A-Za-z0-9]*i[^A-Za-z0-9]*z[^A-Za-z0-9]*e\\b', 'gm')
const str = `mediatize
m_e_d_i_a_t_i_z_e
m e d i a t i z e
m__e__d__i__a__t__i__z__e
m·e·d·i·a·t·i·z·e
MEDIATIZE
M_E_D_I_A_t_i_z_e
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}