# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a href="(?!https?:\/\/)[^"]+">(.*?)<\/a>/$1/g;t' <<< "This string contains a <a href=\"/local/link.html\">local link</a> and a <a href=\"http://remo.te/link.com\">remote link</a>"