import re
regex = re.compile(r"<a href=\"(?!https?://)[^\"]+\">(.*?)</a>")
test_str = "This string contains a <a href=\"/local/link.html\">local link</a> and a <a href=\"http://remo.te/link.com\">remote link</a>"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)