using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""(?!https?://)[^""]+"">(.*?)</a>";
string substitution = @"$1";
string input = @"This string contains a <a href=""/local/link.html"">local link</a> and a <a href=""http://remo.te/link.com"">remote link</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}