const regex = new RegExp('<a href="(?!https?://)[^"]+">(.*?)</a>', 'g')
const str = `This string contains a <a href="/local/link.html">local link</a> and a <a href="http://remo.te/link.com">remote link</a>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);