package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\d+) ?(kg|ml|gallon)(?:.*(water|oil))?`)
var str = `1 kg of water
20 ml water
1 gallon of crude oil
1 kg of diesel
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}