import re
regex = re.compile(r"(\d+) ?(kg|ml|gallon)(?:.*(water|oil))?", flags=re.IGNORECASE)
test_str = ("1 kg of water\n"
"20 ml water\n"
"1 gallon of crude oil\n"
"1 kg of diesel\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")