re = /(\d+) ?(kg|ml|gallon)(?:.*(water|oil))?/i
str = '1 kg of water
20 ml water
1 gallon of crude oil
1 kg of diesel
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end