const regex = /(\d+) ?(kg|ml|gallon)(?:.*(water|oil))?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+) ?(kg|ml|gallon)(?:.*(water|oil))?', 'gi')
const str = `1 kg of water
20 ml water
1 gallon of crude oil
1 kg of diesel
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}