# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d{0,6}(\.\d{1,2})?$/\n/gm;t' <<< "123456.12
21231
123456
15465.43
23.34
6.45
12345678
123456.331"