re = /^\d{0,6}(\.\d{1,2})?$/m
str = '123456.12
21231
123456
15465.43
23.34
6.45
12345678
123456.331'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result