import re
regex = re.compile(r"^\d{0,6}(\.\d{1,2})?$", flags=re.MULTILINE)
test_str = ("123456.12\n"
"21231\n"
"123456\n"
"15465.43\n"
"23.34\n"
"6.45\n"
"12345678\n"
"123456.331")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)