using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{0,6}(\.\d{1,2})?$";
string substitution = @"\n";
string input = @"123456.12
21231
123456
15465.43
23.34
6.45
12345678
123456.331";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}