import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(?:(?:[^\"]*\"){2})*[^\"]*$)\\\\n";
final String string = "11, 12, \"inside\\n the\\n quotes\", 13, 14\\n21, 22, \"another \\ntest\\n case\", 23, 24";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}