import re
regex = re.compile(r"(?=(?:(?:[^\"]*\"){2})*[^\"]*$)\\n")
test_str = "11, 12, \"inside\\n the\\n quotes\", 13, 14\\n21, 22, \"another \\ntest\\n case\", 23, 24"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)