$re = '/(?=(?:(?:[^"]*"){2})*[^"]*$)\\\\n/';
$str = '11, 12, "inside\\n the\\n quotes", 13, 14\\n21, 22, "another \\ntest\\n case", 23, 24';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;