use strict;
my $str = '11, 12, "inside\\n the\\n quotes", 13, 14\\n21, 22, "another \\ntest\\n case", 23, 24';
my $regex = qr/(?=(?:(?:[^"]*"){2})*[^"]*$)\\n/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";