re = /(?=(?:(?:[^"]*"){2})*[^"]*$)\\n/
str = '11, 12, "inside\\n the\\n quotes", 13, 14\\n21, 22, "another \\ntest\\n case", 23, 24'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result