# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?=[^,]+,[^,]*$).*$//g;t' <<< "09-27,09-28,10-01,10-02"