$re = '/,(?=[^,]+,[^,]*$).*$/';
$str = '09-27,09-28,10-01,10-02';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;