use strict;
my $str = '09-27,09-28,10-01,10-02';
my $regex = qr/,(?=[^,]+,[^,]*$).*$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";