using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=[^,]+,[^,]*$).*$";
string substitution = @"";
string input = @"09-27,09-28,10-01,10-02";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}