#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ",(?=[^,]+,[^,]*$).*$"
Local $sString = "09-27,09-28,10-01,10-02"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)