#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"[^"]+"|(?:^\S+|\W-\S+)(*SKIP)(*F)|\S+"
Local $sString = "test --par2 --par23=whatever 0 xd true hello "string test"" & @CRLF & _
"or" & @CRLF & _
"test --par23=whatever 0 xd true hello --par2 "string test"" & @CRLF & _
"or" & @CRLF & _
"test 0 xd "string test" true hello --par2 --par23=whatever"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")