use strict;
my $str = 'test --par2 --par23=whatever 0 xd true hello "string test"
or
test --par23=whatever 0 xd true hello --par2 "string test"
or
test 0 xd "string test" true hello --par2 --par23=whatever';
my $regex = qr/"[^"]+"|(?:^\S+|\W-\S+)(*SKIP)(*F)|\S+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}