// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[^"]+"|(?:^\S+|\W-\S+)(*SKIP)(*F)|\S+"#).unwrap();
let string = "test --par2 --par23=whatever 0 xd true hello \"string test\"
or
test --par23=whatever 0 xd true hello --par2 \"string test\"
or
test 0 xd \"string test\" true hello --par2 --par23=whatever";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}