re = /"[^"]+"|(?:^\S+|\W-\S+)(*SKIP)(*F)|\S+/m
str = 'test --par2 --par23=whatever 0 xd true hello "string test"
or
test --par23=whatever 0 xd true hello --par2 "string test"
or
test 0 xd "string test" true hello --par2 --par23=whatever'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end