import Foundation
let pattern = #""[^"]+"|(?:^\S+|\W-\S+)(*SKIP)(*F)|\S+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
test --par2 --par23=whatever 0 xd true hello "string test"
or
test --par23=whatever 0 xd true hello --par2 "string test"
or
test 0 xd "string test" true hello --par2 --par23=whatever
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)