#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:[^\d#-]){2,}).*$"
Local $sString = "UPS1Z3734A345" & @CRLF & _
"UPS 1Z68A3125" & @CRLF & _
"HOME DEPOT #3421" & @CRLF & _
"STAPLES - #123" & @CRLF & _
"STPLS #4560"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")