using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[^\d#-]){2,}).*$";
string input = @"UPS1Z3734A345
UPS 1Z68A3125
HOME DEPOT #3421
STAPLES - #123
STPLS #4560";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}