const regex = /((?:[^\d#-]){2,}).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:[^\\d#-]){2,}).*$', 'gm')
const str = `UPS1Z3734A345
UPS 1Z68A3125
HOME DEPOT #3421
STAPLES - #123
STPLS #4560`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}