re = /((?:[^\d#-]){2,}).*$/m
str = 'UPS1Z3734A345
UPS 1Z68A3125
HOME DEPOT #3421
STAPLES - #123
STPLS #4560'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end