#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?Usmi)<link.*href(?:-_)?=("|\')(.*)("|\')"
Local $sString = "<link id="termin-btn-menu" href="https://calendly.com/assets/external/widget.css" rel="stylesheet">" & @CRLF & _
"<link id="termin-btn-menu" consent-original-href-_="https://calendly.com/assets/external/widget.css" rel="stylesheet">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")