// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?Usmi)<link.*href(?:-_)?=("|\')(.*)("|\')"#).unwrap();
let string = "<link id=\"termin-btn-menu\" href=\"https://calendly.com/assets/external/widget.css\" rel=\"stylesheet\">
<link id=\"termin-btn-menu\" consent-original-href-_=\"https://calendly.com/assets/external/widget.css\" rel=\"stylesheet\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}