use strict;
my $str = '<link id="termin-btn-menu" href="https://calendly.com/assets/external/widget.css" rel="stylesheet">
<link id="termin-btn-menu" consent-original-href-_="https://calendly.com/assets/external/widget.css" rel="stylesheet">
';
my $regex = qr#<link.*href(?:-_)?=("|\')(.*)("|\')#smip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}