re = /<link.*href(?:-_)?=("|\')(.*)("|\')/mi
str = '<link id="termin-btn-menu" href="https://calendly.com/assets/external/widget.css" rel="stylesheet">
<link id="termin-btn-menu" consent-original-href-_="https://calendly.com/assets/external/widget.css" rel="stylesheet">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end