$re = '#<link.*href(?:-_)?=("|\')(.*)("|\')#Usmi';
$str = '<link id="termin-btn-menu" href="https://calendly.com/assets/external/widget.css" rel="stylesheet">
<link id="termin-btn-menu" consent-original-href-_="https://calendly.com/assets/external/widget.css" rel="stylesheet">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);