using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-z]([\w\d_\.])*@[\w\d_]+\.[A-z](\w{1,3})$";
string input = @"bbkbbk.com
bb123.com
b_knapp@gmail.com
123
bbkbbk132@gmail.na
asdf_3k3k.@hotmail.euaksl
bbkbbkK132_@gmail.net";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}