import Foundation
let pattern = #"^[A-z]([\w\d_\.])*@[\w\d_]+\.[A-z](\w{1,3})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
bbkbbk.com
bb123.com
b_knapp@gmail.com
123
bbkbbk132@gmail.na
asdf_3k3k.@hotmail.euaksl
bbkbbkK132_@gmail.net
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)