package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-z]([\w\d_\.])*@[\w\d_]+\.[A-z](\w{1,3})$`)
var str = `bbkbbk.com
bb123.com
b_knapp@gmail.com
123
bbkbbk132@gmail.na
asdf_3k3k.@hotmail.euaksl
bbkbbkK132_@gmail.net`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}