use strict;
my $str = 'bbkbbk.com
bb123.com
b_knapp@gmail.com
123
bbkbbk132@gmail.na
asdf_3k3k.@hotmail.euaksl
bbkbbkK132_@gmail.net';
my $regex = qr/^[A-z]([\w\d_\.])*@[\w\d_]+\.[A-z](\w{1,3})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}