using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b[1-9][\d\.]+([kmbt]|\s))";
string input = @"12.39 12.39 12.39
12.389k
99.1003b
40.1m
10
10m
0.0
12.00b
1e3
2^5
0xFF
12.6z
asdf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}