$re = '/(\b[1-9][\d\.]+([kmbt]|\s))/';
$str = '12.39 12.39 12.39
12.389k
99.1003b
40.1m
10
10m
0.0
12.00b
1e3
2^5
0xFF
12.6z
asdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);