import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b[1-9][\\d\\.]+([kmbt]|\\s))";
final String string = "12.39 12.39 12.39\n"
+ "12.389k\n"
+ "99.1003b\n"
+ "40.1m\n"
+ "10\n"
+ "10m\n\n"
+ "0.0\n"
+ "12.00b\n"
+ "1e3\n"
+ "2^5\n"
+ "0xFF\n"
+ "12.6z\n"
+ "asdf";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}