const regex = /(\b[1-9][\d\.]+([kmbt]|\s))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b[1-9][\\d\\.]+([kmbt]|\\s))', 'g')
const str = `12.39 12.39 12.39
12.389k
99.1003b
40.1m
10
10m
0.0
12.00b
1e3
2^5
0xFF
12.6z
asdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}