import re
regex = re.compile(r"(\b[1-9][\d\.]+([kmbt]|\s))")
test_str = ("12.39 12.39 12.39\n"
"12.389k\n"
"99.1003b\n"
"40.1m\n"
"10\n"
"10m\n\n"
"0.0\n"
"12.00b\n"
"1e3\n"
"2^5\n"
"0xFF\n"
"12.6z\n"
"asdf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")